VPS推荐与主机测评

关于WEB应用时服务器安装MySQL版本的注意事项

最近这段时间蜗牛比较忙,更新的一些信息和解决方案的案例应该是前几天有遇到的记录下来的。一来是应付看到每天都在更新,二来也是对于知识的积累。比如前几天有在解决一个网友的WEB服务器中安装MYSQL数据库的问题。事情的起因是他在购买一台新的服务器,且安装WEB环境之后需要将原来的网站搬迁进来。

但是在搬迁过程中出现问题,蜗牛帮助在服务器中看到他居然是安装的MYSQL8.0版本,而且我看到他原来服务器中老网站的数据库是5.5版本(好像也是我之前帮他安装的)。肯定是数据库不兼容导致的,但是用肯定还是可以的,只要将数据中的字符替换也是可以导入的。但是我感觉他直接安装这样的版本是没有必要的。

我们有些时候在安装WEB环境的时候是不是也建议服务器的基础配置,比如在安装LNMP一键包的时候是可以看到LNMP脚本中如果需要安装MySQL5.6+,看到的建议是\”安装MySQL 5.6或5.7及MariaDB 10必须1G以上内存,更高版本至少要2G内存\”。我看到其服务器的配置就1GB内存,所以我建议他将MYSQL降低到5.5.于是基于这篇文章,蜗牛的个人看法是,虽然版本高的数据库有一定的优势,但是也需要看到实际的需求和服务器配置。

比如我们在使用2GB内存左右的服务器的时候,蜗牛建议安装MYSQL5.5版本就足够,如果是4GB内存及以上我一般是安装MYSQL5.7版本的。同理,如果是需要安装PHP版本,建议很多CMS要求7.0+,但是建议是需要和缓存一起使用的,所以配置一般也需要2GB内存以上。

同样的,如果我们是需要安装CENTOS8的时候,根据官方的建议是需要4GB内存以上的。这篇文章有点啰嗦,主要是根据前几天遇到的问题简单的谈谈看法。同时,蜗牛需要提醒的是,我们在备份网站数据库的时候,建议多备份几个版本方式。之前遇到一个网友从PHPMYADMIN导出的数据库是不完整的,最后倒入是有错误的。

赞(0)
未经允许不得转载:快上车博客 - 国外VPS,国外服务器,国外主机,测评及优惠码 » 关于WEB应用时服务器安装MySQL版本的注意事项

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址